Magic Mail Monitor 3

Bienvenue dans l'aide de Magic Mail Monitor !

A quoi sert Magic Mail Monitor?

Magic Mail Monitor (MMM) est un notificateur de courrier POP3 multi-compte. Il se place silencieusement dans votre zone de notification et vous prévient de l'arrivée de nouveaux messages dans l'une de vos boîtes aux lettres. Alors, vous pouvez les prévisualiser et supprimer les messages non désirés pour éviter les spams et les virus.

MMM a été développé au début par Valeriy Ovechkin ( http://www.geeba.org/). Malheureusement, il a eu du mal à supporter la popularité de son logiciel, et à partir de la version 2.9, il a distribué le code source sous licence GPL. Avec ce projet, je vais essayer de continuer le développement de Magic Mail Monitor, car je crois que c'est un des meilleurs utilitaires de cette sorte disponible sur Internet.

Plus de détails sur Magic Mail Monitor et les précédentes versions sont disponibles sur son site original : http://www.geeba.org/magic/

Améliorations

Les plus importants changements depuis la dernière version officielle 2.9 sont :
+ des Filtres!
+ la liste d'amis
+ lu/non lu logique
+ interface multilingue
+ possibilité de ne télécharger que les premiers Ko d'un message en prévisualisation
+ possibilité d'afficher les lignes d'entêtes dans les propriétés du courrier
+ Support de l'encodage KOI8 et UTF8

Autres langues

MMM dispose d'un interface multi-langue. Vérifier les traductions disponibles ici. Ou créer votre propre traduction !

Est-ce que MMM est gratuit?

Oui , Magic Mail Monitor est entièrement gratuit. Le code source est disponible aussi dans la section téléchargement .


Les nouveautés de cette version

Quoi de neuf dans cette version ?

2.94b19, 28 janvier 2009

  • Cette version ne fait que corriger une erreur SSL error, merci à Krampo pour cette bonne suggestion!

2.94b18, 12 october 2007

  • corrections dans le support SSL ;
  • quelques autres erreurs corrigées.

2.94b17, 2 october 2007

  • Support SSL pour les boîtes gmail, yahoo, etc...;

2.94.b16, 21 avril 2007.

  • Stockage optionnel des paramètres dans un fichier ini - créer un fichier magic.ini pour l'activer ; Les messages protégés ne pourront pas être supprimés ; Nouvelles actions pour les filtres : protection et traiter comme ami ; Protection possible des messages des amis ; L'éditeur pour visualiser les messages peut être choisir ;
  • Option "Aller à la fin " dans l'affichage des entêtes ;

2.94.b14, 22 décembre 2006.

  • Affichage d'une bulle multiligne pour les sujets longs;
  • Tri possible par heure de vérification des messages;
  • Ligne correspondant au fichier de filtre affiché dans les propriétés du message;
  • Correction d'un problème avec le démarrage caché à partir d'un état maximisé;

2.94b13, 9 mars 2006.

  • Correction d'un problème avec la vérification pendant le téléchargement des messages
  • Compatibilité améliorées avec les nouvelles icônes pour Win9x

2.94.b12, 1er mars 2006.

  • Ajout de la prise en charge d'icônes de grande taille en pleine couleurs dans la barre d'outils.
  • Ajout d'une option pour une meilleure prise en charge de gmail.com - No RETR;
  • Ajout de l'option pour vérifier une boîte aux lettres par double-clic;
  • Le mode "Demander le mot de passe " fonctionne maintenant;
  • Vous pouvez personnaliser la police pour la liste de courriers;
  • La vérification directe rafraîchira aussi les boîtes aux lettres désactivées;
  • Le copier/coller de fichiers entre boîtes aux lettres est maintenant supporté;
  • L'aide inclut la description de la prise en charge des web-mail;
2.94.b11, 23 mai 2005.
  • Correction de quelques bugs;
  • Ajout d'une option pour tenir un journal des messages detruits manuellement;
  • Ajout de la prise en charge des caractères accentués dans les filtres RegExp ;

2.94.b10, 3 avril 2004.

  • amélioration des filtres RegExp et de la syntaxe ;
  • Ajout du'n tester de RegExp, voir l'aide;
  • Sauvegarde automatique en quittant;
  • Correction d'un bug avec les noms des colonnes dans les versions localisées;
  • Ajout d'une option pour une instance unique;
  • Nouveaux raccourcis;

2.94.b9, 27 novembre 2003.

  • de nouveaux filtres: par regexp et par date ;
  • "ajouter aux listes" dans le menu contextuel ;
  • les boîtes aux lettres sont affichées en gras quand elles contiennent des messages non lus ;
  • des boutons pour supprimer tous les messages marqués comme SPAM, pour marquer ou non comme SPAM et pour voir le journal des messages supprimés ;
  • des actions paramétrable par un double clic sur le message ;
  • l'importation des comptes à partir de OE pour les nouvelles boîtes ;
  • la possibilité de skin externes pour la barre d'outils ;
  • la correciton de nombreux bugs dans l'interface ;


Working with Web-mail mailboxes

Comment se servir d'un webmail ?

Actuellement MMM n'est qu'un vérificateur de comptes POP3, donc il ne peut pas travailler directement avec des serveurs comme hotmail.com, yahoo.com et gmail.com. La raison en est que ces serveurs utilisent d'autres protocoles non supportés par MMM.

Cependant quelquefois il y a des solutions de contournement. Il y a des programmes spéciaux , appelés proxy, qui peut fonctionner comme intermédiaire entre MMM et de tels serveurs. MMM échangera avec ces proxy de manière classique et le proxy convertira les commandes POP3 de MMM en commandes pour le serveur.

Comme exemple de serveur universel, nous recommandons d'essayer le projet FreePops.org. Comme vous pouvez le deviner,ce programme gratuit permet un accès POP3 pour différents serveurs de webmail. En fait, il couvre les serveurs les plus populaires,comme s gmail.com, yahoo.com, hotmail.com, aol.com, fastmail.com etc.

Voici une façon d'utiliser FreePops avec MMM:

  • Télécharger le proxy à http://www.freepops.org/en/download-win.shtml. Le fichier d'installation fait environ 800K. Installer le programme , ou simplement décompresser le si vous avez télécharger l'archive. Si MMM est dans vos programmes de démarrage, il faut aussi y ajouter freepopsd.exe . Configurer les boîtes aux lettres dans MMM:
    • serveur = localhost. Ce un nom système spécial qui pointe directement sur le serveur qui tourne sur votre PC - proxy dans notre cas;
nom  = votre adresse mail complète, comme mymailbox@gmail.com;
mot de passe  = votre mot de passe actuel pour la boîte aux lettres ;
port  = 2000. Cet le port par défaut de FreePops, si vous devez le changer - vérifier la documentation de FreePops.
    • Si c'est une boîte gmail - ne pas oublier de cocher l'option "No RETR".
  • Démarrer le proxy FreePops, si vous ne l'avez pas déjà fait. Noter que vous pouvez le démarrer comme un simple application (freepopsd.exe) ou commme un service. Si vous ne savez pas ce qu'est un service, utilisement simplement comme une application.
Maintenant MMM devrait être capable de vérfier le courrier de vos boîtes aux lettres webmail. Si ce n'est pas le cas - lire le manuel de FreePops, qui pourra peut-être vous aider. L'auteur a testé les fonctionnalité de MMM avec des boîtes gmail et hotmail.


Utilisation avec une clé USB

Utilisation avec une clé USB (portabilité)

Maintenant MMM peut utiliser un fichier ini pour stocker ses paramètres, ainsi vous pouvez utiliser cette petite application sur une clé USB ou la configurer localement pour transférer facilement tous les paramètres sur un autre PC.

Par défaut MMM utilise le registre pour le stockage. Pour activer l'utilisation d'un fichier ini, vous devez créer manuellement un fichier vide magic.ini dans le dossier de magic.exe et redémarrer MMM. Il détectera que le fichier est vide, et chargera tous les paramètres à partir du registre et les sauvera dans le fichier à la fermeture.

Maintenant vous pouvez transférer de façon sûre MMM vers un autre PC ou sur une carte flash - Il conservera tous les paramètres dans le fichier magic.ini.

Les fichiers nécéssaires au minimum pour un fonctionnement portable sont les suivants :

  • magic.exe - l'application elle-même
  • magic.ini - stockage des paramètres

  • *.magic - les paramètres de vos boîtes à lettres et les filtres

  • tous les autres fichiers supplémentaires contenant des listes auxquels vous faîtes référence dans vos filtres, habituellment en .txt

    Il est aussi recommandé de récupérer la version MinimumDependance - c'est un peu plus gros, mais nécessite moins de dépendances DLL additionnelles


Propriétés des commandes de Notification

MMM vous permet de lancer un programme externet quand un nouveau courrier arrive dans une boîte aux lettres particulière.

Ces options vous permettent de spécifier les options par défaut qui sont appelées par le menu Fichier/Préférences :

Notification

Aucune – aucune commande ne sera exécutée pour les boîtes aux lettres qui ont l’option Défaut sélectionnée dans le champ Notification ;

Défaut – les paramétrages pour Lancer et Commande seront utilisés pour les boîtes aux lettres qui ont l’option Défaut sélectionnée dans le champ Notification ;

Les options suivantes vous permettent de spécifier les propriétés d’une boîte aux lettres ou d’un groupe de boîtes aux lettres que vous avez sélectionnés par le menu Edition/Propriétés :

Notification

Aucune – aucune commande ne sera exécutée pour les boîtes aux lettres ;

Spécifique – les boîtes de dialogue Lancer et Commande sont accessibles et permettent de définir les options spécifiques de notification pour les boîtes aux lettres ;

Défaut – les paramètres du menu Fichier/Préférences seront utilisés pour les boîtes aux lettres sélectionnées ;

Lancer

Taille normale– la commande tapée dans le champ Commande sera lancée dans une fenêtre de taille normale ;

Minimisé – la commande tapée dans le champ Commande sera lancée dans une fenêtre réduite ;

Maximisé – la commande tapée dans le champ Commande sera lancée dans une fenêtre agrandie ;

Caché – la commande tapée dans le champ Commande sera lancée dans une fenêtre cachée ;

Commande

Entrez une ligne de commande qui sera exécutée à l’arrivée d’un nouveau courrier. Cela peut-être n’importe quel fichier exécutable ou bien un document associé à un fichier – la syntaxe est exactement la même que dans la commande Exécuter de l’explorateur de Windows.

Parcourir

Utilisez ce bouton pour choisir le nom d’un fichier dans le champ Commande au moyen d’une boîte de dialogue standard de windows permettant de parcourir vos fichiers ;

Test

Ce bouton vous permet de lancer la commande que vous avez sélectionnée précédemment ; après chaque changement de paramètres dans cette page, le bouton est grisé, pour le rendre actif, appuyez sur le bouton Appliquer pour enregistrer les changements.


Propriétés générales

Les options suivantes vous permettent de choisir les propriétés d’une boîte aux lettres ou d’un groupe de boîtes aux lettres que vous avez sélectionnés :

Alias

Entrez un nom arbitraire, facile à retenir pour la boîte aux lettres. Si vous laissez cette ligne vide, elle sera automatiquement complétée sous la forme “<user@host>”. Cet alias apparaîtra dans la pop-up de notification d’arrivée de courrier de cette boîte.

Utilisateur

Entrez le nom d’utilisateur de ce compte de courrier. Par exemple, si mon adresse Email est “vvo@geocities.com”, je mettrais “vvo” dans ce champ. Si vous voyez “Nom d’utilisateur ou mot de passe invalides !” dans la colonne de statut, vous devez avoir fait une erreur de frappe dans le Nom d’utilisateur ou le Mot de passe.

Hôte

Entrez l’adresse Internet de votre serveur de courrier (serveur pop). Par exemple, bien que mon adresse email soit “vvo@geocities.com”, je mettrais “mail.geocities.com” ou “204.7.246.132” dans ce champ. Contactez votre administrateur système si vous obtenez le message “ne peut pas se connecter !” or “hôte invalide !” dans la colonne de statut..

Mot de passe

Entrez ici le mot de passe correct. Si vous ne voulez pas que le mot de passe soit enregistré, laissez le champ vide et choisir l'option "Demander le mot de passe" - MMM vous demandera le mot de passe quand il interrogera la boîte aux lettres.

Numéro du port du serveur POP3

Entrez le numéro du port TCP/IP du serveur POP3 (Post Office Protocol v3) de l’hôte spécifié dans le champ Hôte. La valeur par défaut est 110. Si vous obtenez le message “ne peut pas se connecter” dans la colonne statut, contactez votre administrateur système pour obtenir le numéro de port correct pour le service POP3.

Rythme d'interrogation

La fonction principale du programme est la vérification périodique des boîtes aux lettres. Ce champ vous permet de définir l’intervalle de temps en minutes. Vous pouvez souhaitez vérifier plus souvent des boîtes aux lettres “ importantes ” et vice versa.

Télécharger des lignes supplémentaire avec l'entête

MMM peut télécharger plusieurs lignes du message en supplément quand il télécharge l'entête du message. Vous pouvez utiliser cette fonction de deux façons - pour prévisualiser rapidement quelques lignes de chaque messages ou pour corriger un problème avec certains serveurs de courrier qui ne peuvent pas renvoyer l'entête complète dans certains cas.

Désactiver APOP

Cochez cette option si votre serveur de courrier ne prend pas pleinement en charge le protocole APOP, ce qui entraînerait des risques d'instabilité en mode APOP.

Désactiver cette boîte

Cochez cette option pour désactiver complètement cette boîte aux lettres. Notez que vous ne pourrez plus vérifier le courrier sur cette boîte.

Corriger le problème TOP

Certains serveurs de courrier ont des problèmes pour répondre à la commande TOP ce qui entraîne le retour de la même entête pour différents messages. Essayer de paramétrer cette option lors de comportement spécial pour la commande f TOP, uniquement si vous avez le problème décrit ci-dessus.

No RETR (gmail.com)

Utiliser cette option pour relever une boîte aux lettres GMail . Le serveur GoogleMail maruqe le message comme lu si vous le téléchargez avec la commande RETR. Ce qui entraîne la dispartion du message dans la liste de MMM. Cette option forcce MMM à utiliser une méthode de lecture alternative.

NOTE:

Une clé jaune en surimpression de l’icône d’une boîte aux lettres indique que la dernière vérification de la boîte a utilisé le protocole d’authentification sécurisé (APOP command) qui élimine le risque que quelqu’un vole votre mot de passe en interceptant simplement un paquet sur le réseau qui transmet la requête d’authentification au serveur de courrier. Si la clé jaune n’apparaît pas, le mot de passe est transmis en clair. Dans l’idéal, vous souhaiteriez que toutes vos boîtes aux lettres présentent des clés jaunes. Si ce n’est pas le cas, insistez auprès de votre administrateur de serveur courrier pour qu’il installe un serveur POP3 qui supporte la commande APOP ce qui rendra votre compte plus sûr..


Propriétés des en-têtes

Les champs suivants vous permettent de voir les propriétés d’un message sélectionné ou d’un groupe de messages sélectionnés. (si certains champs d’un groupe de messages sélectionnés sont différents, la valeur est remplacée par des points de suspension):

Boîte aux lettres - alias de la boîte aux lettres qui contient le message ;

De - adresse Email ou nom de la personne qui a envoyé le message ;

Sujet - objet du message ;

Date - date à laquelle le message a été expédié (heure locale) ;

Taille - taille du message en octets ou kilooctets (KO).

Filtre - quels filtres seront appliqués à ce message


Options

Les options suivantes vous permettent de définir les options du programme :

Cacher au démarrage

Cochée - Quand vous démarrez Magic Mail Monitor, la fenêtre principale est toujours cachée ;
Décochée - la fenêtre principale s'affichera le mode hérité du raccourci que vous utilisez pour lancer le programme ;

Rafraîchir automatiquement à l’ouverture du document

Cochée - le programme vérifie les boîtes aux lettres immédiatement au lancement du document ;
Décochée – le programme ne vérifie pas immédiatement les boîtes aux lettres au lancement du document ;

Confirmer la suppression des messages

Cochée - une boîte de dialogue de confirmation apparaîtra à chaque fois que vous voudrez supprimer des messages du serveur ;
Décochée – le programme accomplit la suppression des messages dès que la commande est émise ;

Ouvrir la fenêtre principale à l’arrivée d’un nouveau courrier

Cochée - la fenêtre principale s’ouvre à sa position initiale sur le bureau à l’arrivée de nouveaux messages ;
Décochée – la fenêtre conserve sa position initiale (cachée ou minimisée) même quand de nouveaux messages sont détectés ;

Extension des fichiers pour les messages

Cette option spécifie quelle extension doit être utilisée pour les fichiers temporaires créés lors du téléchargement des messages. Cela définit principalement le programme qui sera lancé pour afficher les messages par la commande Voir Vite. Les extensions les plus utilisées sont "txt" pour ouvrir le bloc-notes ou un éditeur de texte ou "eml" pour ouvrir votre client de courrier par défaut pour voir le message. Notez que le lancement de votre client courrier (spécialement Outlook [Express]) n'est pas sûr si le message contient du code html.

Ouvrir avec :

Sélectionner l'application qui sera utilisée pour ouvrir les messages avec l'action Affichage Rapide. Notez que les deux commandes Afficher comme texte et Aperçu ouvriront toujours notepad (ou l'éditeur de texte par défaut du système).

Taille de la prévisualisation, KO

Cette valeur est utilisée par la commande Prévisualisation. Normalement, une valeur de 5 KO devrait suffire pour estimer si le message est utile.

Marquer le message comme lu

Marquage logique des messages lus/non lus. Les valeurs possibles sont :

- toujours : le message est marqué comme lu après avoir reçu l'en-tête ; en conséquence, vous ne verrez jamais un message non lu ;
- si visualisé : le message est marqué comme lu après qu'il ait été ouvert par les commandes Voir Vite ou Prévisualisation ;
- seulement si minimisé : quand MMM est minimisé, tous les messages sont marqués comme lus ;
- si visualisé ou minimisé : combinaison de "si visualisé" et "seulement si mininimisé"


Propriétés des messages de notification

Les options suivantes vous permettent de définir les propriétés pour une boîte aux lettres ou un groupe de boîtes aux lettres sélectionnés :

Notification

Aucune – aucun message pop-up n’apparaîtra pour les boîtes aux lettres sélectionnées ;

Spécifique – un message pop-up de notification apparaîtra pour les boîtes aux lettres sélectionnées ;

Test

Ce bouton vous permet de tester l’apparence du message pop-up ; il est grisé si vous changez les paramètres de Notification, pour le réactiver il faut sélectionner l’option “ Notification spécifique ” et valider avec le bouton Appliquer.


Advanced Options Properties Page

Préférences de l'utilisateur - Avancé

Les options suivantes sont disponibles dans les options avancées :

Enregistrer les messages supprimés

MMM peut enregistrer un journal des messages effacés automatiquement par les filtres. Notez que les messages détruits manuellement ne seront pas inscrits dans le journal. Le fichier du journal s'appelle msgdeleted.log et se trouve dans le même dossier que magic.exe. Vous pouvez changer la taille maximale du fichier journal et quand elle sera atteinte le fichier sera tronqué. Pour désactivé cette coupure automatique, mettre la limite à 0. Dans ce cas, vous devrez détruire ce fichier vous-même de temps en temps.

Utiliser une couleur spéciale pour les messages des amis

Les messages des auteurs présents dans la liste d'amis (friendlst.txt) peuvent être surlignés d'une couleur particulière.

Autoriser une seule instance

Cette option évitera de lancer une autre instance de MMM et en plus elle activera l'instance qui est déjà en train de tourner pour que vous puissiez la voir.

Trier par heure de vérification

Cette option vous aide à voir toujours les nouveaux messages en haut de la liste - comme de nombreux spams n'ont pas une heure correcte.

Vérifier la boîte d' un double-clic

Choisir cette option pour lancer la vérificatoin de la boîte aux lettres après avoir double cliquer sur son nom dans la liste. L'action par défaut est de démarrer l'action associée dans "action".

Police personnalisée

Vous pouvez modifier la police utilisée dans les listes si vous n'aimez pas celle définie par défaut pour quelque raison que ce soit.


Propriétés des animations de notification

MMM peut vous signaler l'arrivée d'un nouveau courrier par un son - soit un morceau de musique d'un CD audio soit un fichier audio.

Les animations de notification (Jouer) sont implémentées en utilisant l’interface du système appelée MCI, (pour Multimedia Control Interface). Normalement, si votre système dispose d’une carte son, il est capable de jouer des fichiers son, donc des fichiers audio wave (.wav), midi (.mid, .rmi),. des fichiers Video de type avi seront supportés par defaut. Si vous avez installés avant des contrôles ActiveX, etc., votre système peut jouer des fichiers MPEG audio ou vidéo. Si vous n’êtes pas sûr des formats supportés , aller dans Panneau de configuration/Multimédia/ Périphériques/Périphériques MCI et jeter un œil à ce qui s’y trouve.

Les options suivantes vous permettent de définir les paramètres par défaut qui seront appelés par le menu Fichiers/Préférences :

Notification

Aucune – aucune animation ne sera jouée pour les boîtes aux lettres qui ont l’option Défaut sélectionnée dans le champ Notification ;

Défaut – Les paramètres des périphériques MCI définis dans Multimedia et dans chemin seront utilisés pour les boîtes aux lettres qui ont l’option Défaut sélectionnée dans le champ Notification ;

Les options suivantes vous permettent de définir les propriétés pour une boîte aux lettres ou un groupe de boîtes aux lettres que vous avez sélectionnés à partir de la commande Edition/Propriétés :

Notification

Aucune – aucune animation ne sera jouée pour les boîtes aux lettres sélectionnées ;

Spécifique – Active la boîte de dialogue Multimedia et Chemin et permet de définir une notification spécifique pour chaque boîte aux lettres sélectionnée ;

Défaut – Les paramètres définis dans le menu Fichiers/Préférences de l’utilisateur seront utilisés pour les boîtes aux lettres sélectionnées ;

Multimédia

Fichier – permet de définir le chemin du fichier qui doit être joué ;

CD Audio – si votre système est capable de jouer des disques compacts audio, il sera joué ;

Chemin

Tapez un chemin valide pour un fichier multimédia que vous voulez faire jouer ; vous devez aussi mettre Multimedia sur l’option Fichier ; si vous souhaitez parcourir votre disque dur au moyen d’une boîte de dialogue standard , utiliser le bouton Parcourir ;

Parcourir

Appuyez sur ce bouton pour entrer le nom du fichier dans le champ Chemin en parcourant votre disque dur au moyen d’un boîte de dialogue standard ;

Test

Ce bouton vous permet de tester la lecture du fichier que vous avez précédemment choisi ; après avoir changé un paramètre sur cette page, le bouton devient grisé et pour l’activer il faut d’abord appuyer sur Appliquer pour sauvegarder les changements.


Actions personnalisées

Vous pouvez changer les actions par défaut déclenchées par un clic de souris dans la liste de messages.

Les différents événements sont :

  • double clic;
  • clic du bouton droit ;
  • clic long du bouton droit - appuyer sur le bouton droit de la souris et le maintenez le appuyé pendant une seconde avant de la relâcher.

Les actions possibles sont :

  • Afficher rapidement ;
  • Afficher le menu contextuel ;
  • Afficher l'entête ;
  • Afficher les propriétés du message;
  • Previsualiser le message;
  • Afficher le message comme texte ;


Skin de la barre d'outils

Personnaliser l'apparence de MMM3

Vous pouvez personnaliser l'apparence de MMM en changeant l'apparence des boutons de la barre d'outils.

  • Créer un fichier bitmap ou télécharger le sur notre page :
    mmm3glyphs.bmp pour la barre d'outils ou
    or
    mmm3small.bmp pour les icônes de la liste
  • placer les dans le même dossier que magic.exe;
  • Après redémarrage, MMM affichera le nouveau jeu d'icônes.

Notez que cette fonction ne marche que sur les systèmes en 24 M de couleurs et plus.

Bitmap de la barre d'outils

  • Nom: mmm3glyphs..bmp;
  • 256, 24b ou 32b couleurs sont supportées;
  • la taille des boutons doit être (largeur x hauteur): 16x15, 24x24, 32x32;

Bitmap des images de la liste

A par le nom spécifique , il y a peu de paramètres supplémentaires pour l'image :

  • Nom: mmm3small.bmp;
  • 256, 24b ou 32b couleurs sont supportées;
  • taille de chaque image:16x16.


Editeur de filtres

Magic Mail Monitor propose des filtres de courrier pour vous aider à trier visuellement les messages. Les filtres sont appliqués dans l'ordre de leur apparition dans la liste des filtres.Vous pouvez activer ou désactiver individuellement les filtres.

Liste d'amis

Vous pouvez créer une liste d'amis expéditeurs, dont les messages ne seront pas filtrés. Editer la liste d'amis en choisissant dans le menu Fichier>Amis. La liste d'amis est contenue dans le fichier friendlst.txt qui est créé automatiquement quand vous accédez pour la 1ère fois à l'élément du menu mentionné ci-dessus.

Appliquer les filtres automatiquement

Si cette option est cochée, les filtres sélectionnés seront appliqués à chaque nouveau message reçu. Sinon vous pouvez appeler la fonction de filtrage manuellement en sélectionnant la commande “ Appliquer les filtres” dans le menu/Fichier.

Nom

Nom du filtre. Dans le futur, ce nom apparaîtra en tant que filtre, appliqué au message.

Boîte aux lettres

Vous pouvez configurer les filtres pour qu'ils ne s'appliquent qu'à la boîte aux lettre sélectionnée ou à toutes les boîtes aux lettres. ("*”)

Champ filtré

Sujet, De, A, CC, En-tête, Taille – identifient à quel champ s'appliquera le présent filtre. Voir aussi Filtrer par date.

Conditions du filtre

Cette option contrôle quel filtre doit être appliqué. Les valeurs possibles sont :

  • Est égal ? : le champ doit être exactement égal au texte du filtre. Autrement, on peut utiliser “*“ comme caractère joker. Ex. *@mail.com
  • Contient : le champ doit contenir le texte du filtre

  • Contient RegExp : le champ doit contenir l'expression regexp

  • Ne contient pas : le champ ne doit pas contenir le texte du filtre
    -> : cette opération ne peut être utilisée que pour le champ Taille. Le filtre sera appliqué si la taille du message est plus grande que celle spécifiée dans le texte du filtre, en octets.

Toutes les comparaisons de texte sont insensibles à la casse.

Texte du filtre

Définit le texte pour la comparison. Pour vérifier le texte d'un fichier, utilisez la syntaxe $nomdufichier , ex: $blacklst.txt.

Le fichier texte à vérifier doit avoir une chaîne à contrôler par ligne.

Actions du filtre

Si le message correspond au filtre, plusieurs actions peuvent être appliquées :

  • Supprimer du serveur : le message sera supprimé immédiatement. Soyez prudent avec cette règle, car aucune confirmation supplémentaire n'est demandée !

  • Marquer comme spam : le message sera marqué avec [SPAM] dans le sujet ;

  • Surligner avec la couleur : le message sera affiché d'une couleur différente ;

  • Marquer comme lu : le message sera marqué comme lu et ne donnera lieu à aucune notification ;

  • Appliquer les autres filtres : si cette option n'est pas cochée, les autres filtres ne seront pas essayés.
  • Protéger: protège le message qui ne peut donc être détruit
  • Traiter comme un ami : Comme cela est suggéré, le messsage sera traité exactement comme s'il provenait d'amis. Notez que cette action exclut automatiquement la suivante.
  • Appliquer les autres filtres: si cette option n'est pas choisie, les autres filtres ne seront pas essayés.


Filtrer par date

Comment filtrer par date ?

Vous pouvez définir un filtre pour sélectionner les messages trop vieux. Il y a deux options possible :

  • le message est ancien de plus de N jours ;
  • le message est plus ancien qu'une certaine date;
Dans les deux cas, vous créer le filtre en spécifiant dans le champ Date l'opération '>' (plus grand que ).

Pour sélectionner les messages de plus de N jours, simplement entrer le nombre de jours dans le champ texte.

Pour sélectionner les messages plus ancien qu'une certaine date, entrer votre date dans le format : dd.mm.yyyy.


RegExp dans les filtres

Qu'est-ce que RegExp?

voir une courte description des Expressions Régulières (RegEx) ici.

Utiliser les expressions régulières dans les filtres

Vous pouvez définir des filtres pour sélectionner des messages en incluant des séquences RegExp dans certains champs. Pour ce faire, sélectionner Contient RegExp dans la condition du filtre et entrez votre expression régulière dans le champ texte.

Exemples de filtres RegExp :
Pour détecter de multiples espaces dans le sujet : \s{5,}
Pour détecter les clones de Viagra : V.AGRA

Sensibilité à la casse

Comme tous les autres filtres, les RegExp ne sont pas sensibles à la casse par défaut. Pour les rendre sensible à la casse, utilisez la syntaxe : /regexp/
Exemple: /\u{3,}/ l' expression 3 majuscules ou plus dans une séquence.

Tester les filtres RegExp

Créer un filtre RegExp fonctionnel peut être une tâche complexe, surtout si vous n'en avez pas utilisés auparavant. Pour tester vos expressions,nous avons ajouter un testeur spécial RegExp . Vous pouvez y entrer la chaîne à tester et l'expression régulière que vous voulez lui appliquer et vérifier que cela fonctionne comme prévu. Vous trouverez le testeur dans le menu Aide/Testeur RegExp. Pour vous aidez, vous trouverez aussi une rapide liste des règles des RegExp.


Utiliser des expressions régulières

Note : traduction de cette page fournie à titre indicatif..(toute amélioration utilisant le langage spécifique aux expressions régulière sera la bienvenue)

Normalement, quand vous faites une recherche sur une sous-chaîne dans une chaîne , l'objet doit être exactement semblable. Ainsi si vous chercher la sous-chaîne "abc" alors la chaîne dans laquelle s'effectue la recherche doit contenir exactement ces lettres dans la même séquence pour qu'un objet soit trouvé.

On peut étendre ce type de recherche avec une recherche insensible à la casse où la sous-chaîne "abc" trouvera les chaînes telles que "Abc", "ABC" et ainsi de suite. Dans ce cas, la casse est ignorée mais la séquence de lettres doit être exactement la même. Quelquefois une recherche insensible à la casse ne suffira pas encore. Par exemple, si on veut faire une recherche sur sur des chiffres, on sera limité basiquement à une rechercher de chaque chiffre indépendamment. C'est là que les expressions régulières peuvent apporter de l'aide.

Les expression régulières sont des modèles de texte qui sont utilisé pour trouver des objets dans des chaînes. Les expressions régulièes sont des chaînes qui contiennent un mélange de texte plein et de caractères spéciaux pour indiquer quelle sorte de rechercher faire. Voila donc un tutorial très bref sur l'utilisation des expressions régulières avant de nous lancer dans le code nécessaire pour manipuler les expressions régulières.

Syntaxe des Expressions Régulières

Littéral
Tous les caractères sont littéraux à l'exception de : ".", "*", "?", "+", "(", ")", "{", "}", "[", "]", "^" et "$". Ces caractères sont littéraux s'ils sont précédés par un "\". Un caractère littéral est un caractère qui correspond à lui-même.

Joker
Le point "." correspond à n'importe quel caractère simple.

Répétitions
Une répétition est une expression qui est répétée un nombre arbitraire de fois.
Une expression suivie par * peut être répétée n'importe quel nombre de fois y compris zéro.
Une expression suivie par + peut être répétée n'importe quel nombre de fois mais au moins une fois.
Une expression suivie par ? peut être répétée zéro ou une fois seulement.
Quand il est nécessaire de préciser le nombre minimum et maximum de répétition explicitement, les limitateurs {} peuvent être utilisés, ainsi "a{2}" est la lettre "a" répétée exactement deux fois, "a{2,4}" représente la lettre "a" répété entre 2 et 4 fois et "a{2,}" représente la lettre "a" répété au moins deux fois sans limite supérieure. Notez qu'il ne doit y avoir aucun espace blanc à l'intérieur de {} et qu'il n'y a pas de limite supérieure aux valeurs entre les deux limitateurs.

Exemples:
    "ba*" correspond à  tous les "b", "ba", "baaa" etc.
    "ba+" correspond à "ba" ou "baaaa" par exemple mait pas à "b".
    "ba?" correspond à "b" ou"ba". "ba{2,4}" correspond à "baa", "baaa" et "baaaa".

Parenthèses
Les parenthèses () sont utilisées pour regrouper des éléments ensemble dans une sous-expression. Par exemple, l'expression "(ab)*"correspondrait à toutes les chaînes "ababab".

Alternatives
Les alternatives se produisent quand l'expression peut correspondre soit à une sous-expression ou à une autre, chaque alternative est séparée par un "|". Chaque alternative est la plus large possible des sous-expressions précédentes; c'est le comportement inverse des opérateurs de répétition.

Exemples: "a(b|c)" pourrait correspondre à "ab" ou "ac". "abc|def" pourrait correspondre à"abc" ou "def".

Jeux

Un jeu est un jeu de caractères qui peut correspondre à n'importe quel caractère simple qui est un membre du jeu. Les jeux sont délimités par "[" et "]" et peuvent contenir des caractères littéraux, des intervalles de caractères et des classes de caractères. La déclaration d'un jeu commence par "^" qui contient le complément des éléments qui suivent.

Exemples:
    Caractères littéraux :
    "[abc]" correspond aussi bien à "a", "b" ou"c".
    "[^abc]" correspond à n'importe quel caractère autre que "a", "b" ou "c".

    Intervalles de caractères :
    "[a-z]" correspond à tous les caractères de "a" à "z".
    "[^A-Z]" correspond à n'importe quel autre caractère autre que ceux compris entre "A" à "Z".

Classes de caractères
Une classe de caractères est une séquence spéciale pour simplifier les types de caractères utilisé habituellement.Les classes disponibles sont :

Classes | Description | Equivalent
\w | N'importe quel caractère - tous les caractères alphanumeriques et le underscore.(_) | [a-zA-Z_]
\s | N'importe quel caractère vide (espaces et tabulations). |
\d | N'importe quel chiffre. | [0-9]
\l | N'importe quel caractère minuscule. | [a-z]
\u | N'importe quel caractère majuscule. | [A-Z]

La version en majuscule de ces classes signifie NON, par exemple, \S désigne les caractères non vides.

Résumé des élements de syntaxe des expressions régulières

Le tableau suivant résume les éléments de syntaxe utilisés dans les expressions régulières.

Caractère | Description
^ | Début de la chaîne. L'expression "^A" concorrespondra à "A" uniquement au début de la chaîne.
^ | L'accent circonflexe (^) immédiatement après le crochet gauche ([) n'a pas le même sens. Il est utilisé pour exclure les caractères restants dans les parenthèses de la chaîne cible correspondante. L'expression "[^0-9]" indique que le caractère cible ne doit pas être un chiffre.
$ | Le signe $ ($) correspond à la fin de la chaîne. L'expression "abc$" correspond à la sous-chaîne "abc" seulement si elle est à la fin de la chaîne.
| | Le caractère (|) autorise la chaîne cible à correspondre à l'un ou l'autre des côtés de l'expression. L'expression "a|b" correspond aussi bien à "a" qu'à "b".
. | Le point (.) correspond à n'importe quel caractère.
* | L'astérisque (*) indique que le caractère à gauche de l'astérisque dans l'expression devrait correspondre zéro ou plusieurs fois.
+ | Le plus (+) est similaire à l'astérisque mais il doit y avoir au moins une correspondance d'un caractère à gauche du signe + de l'expression.
? | Le point d'interrogation (?) correspond au caractère à sa gauche 0 ou 1 fois.
() | Les parenthères affectent l'ordre de modèles d'évaluation et aussi servent à marquer l'expression qui peut être utilisée quand on remplace la sous-chaîne correspondante par une autre expression.
[] | Les crochets ([ and ]) encadrent un jeu de caractères et indiquent que n'importe quel caractères encadrés peut correspondre au caractère cible.
{N} | Répète l'expression exactement N fois.
{N, M} | Répète l'expression entre N et M fois.
{N, } | Répète l'expression N fois ou plus.


Licence de MMM3 !

Magic Mail Monitor est distribué sous les conditions suivantes :

GNU GENERAL PUBLIC LICENSE

Version 2, June 1991

Copyright (C) 1989, 1991 Free Software Foundation, Inc.
59 Temple Place - Suite 330, Boston, MA  02111-1307, USA

Everyone is permitted to copy and distribute verbatim copies
of this license document, but changing it is not allowed.

Preamble

The licenses for most software are designed to take away your freedom to share and change it. By contrast, the GNU General Public License is intended to guarantee your freedom to share and change free software--to make sure the software is free for all its users. This General Public License applies to most of the Free Software Foundation's software and to any other program whose authors commit to using it. (Some other Free Software Foundation software is covered by the GNU Library General Public License instead.) You can apply it to your programs, too.

When we speak of free software, we are referring to freedom, not price. Our General Public Licenses are designed to make sure that you have the freedom to distribute copies of free software (and charge for this service if you wish), that you receive source code or can get it if you want it, that you can change the software or use pieces of it in new free programs; and that you know you can do these things.

To protect your rights, we need to make restrictions that forbid anyone to deny you these rights or to ask you to surrender the rights. These restrictions translate to certain responsibilities for you if you distribute copies of the software, or if you modify it.

For example, if you distribute copies of such a program, whether gratis or for a fee, you must give the recipients all the rights that you have. You must make sure that they, too, receive or can get the source code. And you must show them these terms so they know their rights.

We protect your rights with two steps: (1) copyright the software, and (2) offer you this license which gives you legal permission to copy, distribute and/or modify the software.

Also, for each author's protection and ours, we want to make certain that everyone understands that there is no warranty for this free software. If the software is modified by someone else and passed on, we want its recipients to know that what they have is not the original, so that any problems introduced by others will not reflect on the original authors' reputations.

Finally, any free program is threatened constantly by software patents. We wish to avoid the danger that redistributors of a free program will individually obtain patent licenses, in effect making the program proprietary. To prevent this, we have made it clear that any patent must be licensed for everyone's free use or not licensed at all.

The precise terms and conditions for copying, distribution and modification follow.

TERMS AND CONDITIONS FOR COPYING, DISTRIBUTION AND MODIFICATION

0. This License applies to any program or other work which contains a notice placed by the copyright holder saying it may be distributed under the terms of this General Public License. The "Program", below, refers to any such program or work, and a "work based on the Program" means either the Program or any derivative work under copyright law: that is to say, a work containing the Program or a portion of it, either verbatim or with modifications and/or translated into another language. (Hereinafter, translation is included without limitation in the term "modification".) Each licensee is addressed as "you".

Activities other than copying, distribution and modification are not covered by this License; they are outside its scope. The act of running the Program is not restricted, and the output from the Program is covered only if its contents constitute a work based on the Program (independent of having been made by running the Program). Whether that is true depends on what the Program does.

1. You may copy and distribute verbatim copies of the Program's source code as you receive it, in any medium, provided that you conspicuously and appropriately publish on each copy an appropriate copyright notice and disclaimer of warranty; keep intact all the notices that refer to this License and to the absence of any warranty; and give any other recipients of the Program a copy of this License along with the Program.

You may charge a fee for the physical act of transferring a copy, and you may at your option offer warranty protection in exchange for a fee.

2. You may modify your copy or copies of the Program or any portion of it, thus forming a work based on the Program, and copy and distribute such modifications or work under the terms of Section 1 above, provided that you also meet all of these conditions:

  • a) You must cause the modified files to carry prominent notices stating that you changed the files and the date of any change.

  • b) You must cause any work that you distribute or publish, that in whole or in part contains or is derived from the Program or any part thereof, to be licensed as a whole at no charge to all third parties under the terms of this License.

  • c) If the modified program normally reads commands interactively when run, you must cause it, when started running for such interactive use in the most ordinary way, to print or display an announcement including an appropriate copyright notice and a notice that there is no warranty (or else, saying that you provide a warranty) and that users may redistribute the program under these conditions, and telling the user how to view a copy of this License. (Exception: if the Program itself is interactive but does not normally print such an announcement, your work based on the Program is not required to print an announcement.)

These requirements apply to the modified work as a whole. If identifiable sections of that work are not derived from the Program, and can be reasonably considered independent and separate works in themselves, then this License, and its terms, do not apply to those sections when you distribute them as separate works. But when you distribute the same sections as part of a whole which is a work based on the Program, the distribution of the whole must be on the terms of this License, whose permissions for other licensees extend to the entire whole, and thus to each and every part regardless of who wrote it.

Thus, it is not the intent of this section to claim rights or contest your rights to work written entirely by you; rather, the intent is to exercise the right to control the distribution of derivative or collective works based on the Program.

In addition, mere aggregation of another work not based on the Program with the Program (or with a work based on the Program) on a volume of a storage or distribution medium does not bring the other work under the scope of this License.

3. You may copy and distribute the Program (or a work based on it, under Section 2) in object code or executable form under the terms of Sections 1 and 2 above provided that you also do one of the following:

  • a) Accompany it with the complete corresponding machine-readable source code, which must be distributed under the terms of Sections 1 and 2 above on a medium customarily used for software interchange; or,

  • b) Accompany it with a written offer, valid for at least three years, to give any third party, for a charge no more than your cost of physically performing source distribution, a complete machine-readable copy of the corresponding source code, to be distributed under the terms of Sections 1 and 2 above on a medium customarily used for software interchange; or,

  • c) Accompany it with the information you received as to the offer to distribute corresponding source code. (This alternative is allowed only for noncommercial distribution and only if you received the program in object code or executable form with such an offer, in accord with Subsection b above.)

The source code for a work means the preferred form of the work for making modifications to it. For an executable work, complete source code means all the source code for all modules it contains, plus any associated interface definition files, plus the scripts used to control compilation and installation of the executable. However, as a special exception, the source code distributed need not include anything that is normally distributed (in either source or binary form) with the major components (compiler, kernel, and so on) of the operating system on which the executable runs, unless that component itself accompanies the executable.

If distribution of executable or object code is made by offering access to copy from a designated place, then offering equivalent access to copy the source code from the same place counts as distribution of the source code, even though third parties are not compelled to copy the source along with the object code.

4. You may not copy, modify, sublicense, or distribute the Program except as expressly provided under this License. Any attempt otherwise to copy, modify, sublicense or distribute the Program is void, and will automatically terminate your rights under this License. However, parties who have received copies, or rights, from you under this License will not have their licenses terminated so long as such parties remain in full compliance.

5. You are not required to accept this License, since you have not signed it. However, nothing else grants you permission to modify or distribute the Program or its derivative works. These actions are prohibited by law if you do not accept this License. Therefore, by modifying or distributing the Program (or any work based on the Program), you indicate your acceptance of this License to do so, and all its terms and conditions for copying, distributing or modifying the Program or works based on it.

6. Each time you redistribute the Program (or any work based on the Program), the recipient automatically receives a license from the original licensor to copy, distribute or modify the Program subject to these terms and conditions. You may not impose any further restrictions on the recipients' exercise of the rights granted herein. You are not responsible for enforcing compliance by third parties to this License.

7. If, as a consequence of a court judgment or allegation of patent infringement or for any other reason (not limited to patent issues), conditions are imposed on you (whether by court order, agreement or otherwise) that contradict the conditions of this License, they do not excuse you from the conditions of this License. If you cannot distribute so as to satisfy simultaneously your obligations under this License and any other pertinent obligations, then as a consequence you may not distribute the Program at all. For example, if a patent license would not permit royalty-free redistribution of the Program by all those who receive copies directly or indirectly through you, then the only way you could satisfy both it and this License would be to refrain entirely from distribution of the Program.

If any portion of this section is held invalid or unenforceable under any particular circumstance, the balance of the section is intended to apply and the section as a whole is intended to apply in other circumstances.

It is not the purpose of this section to induce you to infringe any patents or other property right claims or to contest validity of any such claims; this section has the sole purpose of protecting the integrity of the free software distribution system, which is implemented by public license practices. Many people have made generous contributions to the wide range of software distributed through that system in reliance on consistent application of that system; it is up to the author/donor to decide if he or she is willing to distribute software through any other system and a licensee cannot impose that choice.

This section is intended to make thoroughly clear what is believed to be a consequence of the rest of this License.

8. If the distribution and/or use of the Program is restricted in certain countries either by patents or by copyrighted interfaces, the original copyright holder who places the Program under this License may add an explicit geographical distribution limitation excluding those countries, so that distribution is permitted only in or among countries not thus excluded. In such case, this License incorporates the limitation as if written in the body of this License.

9. The Free Software Foundation may publish revised and/or new versions of the General Public License from time to time. Such new versions will be similar in spirit to the present version, but may differ in detail to address new problems or concerns.

Each version is given a distinguishing version number. If the Program specifies a version number of this License which applies to it and "any later version", you have the option of following the terms and conditions either of that version or of any later version published by the Free Software Foundation. If the Program does not specify a version number of this License, you may choose any version ever published by the Free Software Foundation.

10. If you wish to incorporate parts of the Program into other free programs whose distribution conditions are different, write to the author to ask for permission. For software which is copyrighted by the Free Software Foundation, write to the Free Software Foundation; we sometimes make exceptions for this. Our decision will be guided by the two goals of preserving the free status of all derivatives of our free software and of promoting the sharing and reuse of software generally.

NO WARRANTY

11. BECAUSE THE PROGRAM IS LICENSED FREE OF CHARGE, THERE IS NO WARRANTY FOR THE PROGRAM, TO THE EXTENT PERMITTED BY APPLICABLE LAW. EXCEPT WHEN OTHERWISE STATED IN WRITING THE COPYRIGHT HOLDERS AND/OR OTHER PARTIES PROVIDE THE PROGRAM "AS IS" WITHOUT WARRANTY OF ANY KIND, EITHER EXPRESSED OR IMPLIED, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE. THE ENTIRE RISK AS TO THE QUALITY AND PERFORMANCE OF THE PROGRAM IS WITH YOU. SHOULD THE PROGRAM PROVE DEFECTIVE, YOU ASSUME THE COST OF ALL NECESSARY SERVICING, REPAIR OR CORRECTION.

12. IN NO EVENT UNLESS REQUIRED BY APPLICABLE LAW OR AGREED TO IN WRITING WILL ANY COPYRIGHT HOLDER, OR ANY OTHER PARTY WHO MAY MODIFY AND/OR REDISTRIBUTE THE PROGRAM AS PERMITTED ABOVE, BE LIABLE TO YOU FOR DAMAGES, INCLUDING ANY GENERAL, SPECIAL, INCIDENTAL OR CONSEQUENTIAL DAMAGES ARISING OUT OF THE USE OR INABILITY TO USE THE PROGRAM (INCLUDING BUT NOT LIMITED TO LOSS OF DATA OR DATA BEING RENDERED INACCURATE OR LOSSES SUSTAINED BY YOU OR THIRD PARTIES OR A FAILURE OF THE PROGRAM TO OPERATE WITH ANY OTHER PROGRAMS), EVEN IF SUCH HOLDER OR OTHER PARTY HAS BEEN ADVISED OF THE POSSIBILITY OF SUCH DAMAGES.

END OF TERMS AND CONDITIONS


Le savez-vous ?

Raccourcis rapides

Ces raccourcis clavier spéciaux sont utilisés dans le panneaux d'affichage des messages :
  • Gray + - sélectionne tous les messages, exceptés ceux des amis ;
  • Gray * - inverse la sélection;
  • S - switch pour la marque SPAM ;


Autres ressources sur MMM

Vous trouverez ici des liens vers des articles sur MMM, écrit par des supporters enthousiastes du monde entier.

SWEN-virus filter for Magic Mail Monitor 3
http://nakawe.sourceforge.net/MMM3/index.html

Que es Magic Mail Monitor Spanish, for 2.6
http://www.hazlo-asi.net/tutoriales/magicmail.html

Magic Mail Monitor Italian, for 2.6
http://www.wintricks.it/software/magicmail.html

Vous connaissez d'autres articles non référencé ici ? Ou bien vous en avez écrit un dans votre langue? SVP faites le nous savoir - Cela pourra servir pour d'autres utilisateurs !


Support

Obtenir de l'aide pour MMM

Nouvelle page de MMM3 : http://mmm3.sourceforge.net, Merci à SourceForge.net project!

Page originelle de MMM,où vous pouvez trouver la dernière version 2.9 (et de plus anciennes) : http://www.geeba.org/magic/ .

Vous pouvez utiliser le forum de la page de présentation du projet pour poster vos messages/requêtes/rapport d'erreurs sur MMM. Sinon utiliser le questionnaire de la page http://www.grigsoft.com/contact.htm pour me joindre directement.

A propos des auteurs

Magic Mail Monitor a été développé au début par Valeriy Ovechkin ( http://www.geeba.org/)

Mon nom est Igor Green. J'utilise MMM depuis des années maintenant, presque depuis le début. Quelques autres utilitaires que j'ai concu sont sur la page http://www.grigsoft.com

Plusieurs autres personnes m'ont déjà rejoint pour rendre MMM le meilleur notificateur de courrier. Je voudrais les remercier tous et notamment Marco Gulino, Travis Watford, Alexei Smirnov.

Remerciements particuliers pour les icônes en pleine couleur à Yuri Mezentsev (http://mezich.livejournal.com/)
Anciennes icônes produites pas Daniel Bretzmann.


Propriétés du serveur

Les champs suivants donnent des informations détaillées sur le serveur POP3 dont dépend la boîte aux lettres consultée :

Accueil du Serveur– c’est la première réponse en ligne du serveur. Il comprend généralement le nom du logiciel POP3 et sa version et quelques salutations informelles ;

Adresse IP– l’adresse IP du serveur en notation décimale ;

Support APOP – si le serveur autorise l’authentification via une commande APOP. Notez que certains serveurs semble supporter le protocole APOP, et cependant ils répondent toujours négativement à une requête APOP. Certains serveurs peuvent déconnecter après un échec à une requête APOP ;

Support UIDL – cette commande permet au programme de facilement identifier les messages email stockés sur le serveur. Cette commande est optionnelle ;

Support Burst Writes – si le serveur répond à de multiples requêtes envoyées en même temps et par extension quand une commande est envoyée avant de recevoir la réponse du serveur à la précédente. Par exemple, si un client envoie deux requêtes en même temps , certains serveurs répondent à la première commande et ignorent le reste. Magic Mail Monitor utilise “l’écriture en rafale” (burst writes) pour réduire le nombre d’aller-retour pendant un dialogue avec le serveur. Pour détecter le support du protocole “burst writes”, le programme envoie deux commandes consécutives “no-operation” (NOOP) et examine la réponse du serveur.